44 lines
1.5 KiB
Diff
44 lines
1.5 KiB
Diff
From 8ba37a5023f939ba8d2e0d91b916ff442b1c18dd Mon Sep 17 00:00:00 2001
|
|
From: Michal Kubecek <mkubecek@suse.cz>
|
|
Date: Mon, 31 Dec 2018 00:05:42 +0100
|
|
Subject: [PATCH 2/5] modules: replace SUBDIRS with M
|
|
|
|
Since commit 0126be38d988 ("kbuild: announce removal of SUBDIRS if used")
|
|
in v5.0-rc1, using SUBDIRS when building out of tree modules produces
|
|
a deprecation warning. As M used to work since pretty much ever, use it
|
|
unconditionally.
|
|
---
|
|
vmmon-only/Makefile | 2 +-
|
|
vmnet-only/Makefile | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/vmmon-only/Makefile b/vmmon-only/Makefile
|
|
index ccdd295..b4b71fb 100644
|
|
--- a/vmmon-only/Makefile
|
|
+++ b/vmmon-only/Makefile
|
|
@@ -107,7 +107,7 @@ prebuild:: ;
|
|
postbuild:: ;
|
|
|
|
$(DRIVER_KO): prebuild
|
|
- $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
|
|
+ $(MAKE) -C $(BUILD_DIR) M=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
|
|
MODULEBUILDDIR=$(MODULEBUILDDIR) modules
|
|
$(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
|
|
MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
|
|
diff --git a/vmnet-only/Makefile b/vmnet-only/Makefile
|
|
index caab6b9..c2fc51f 100644
|
|
--- a/vmnet-only/Makefile
|
|
+++ b/vmnet-only/Makefile
|
|
@@ -107,7 +107,7 @@ prebuild:: ;
|
|
postbuild:: ;
|
|
|
|
$(DRIVER_KO): prebuild
|
|
- $(MAKE) -C $(BUILD_DIR) SUBDIRS=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
|
|
+ $(MAKE) -C $(BUILD_DIR) M=$$PWD SRCROOT=$$PWD/$(SRCROOT) \
|
|
MODULEBUILDDIR=$(MODULEBUILDDIR) modules
|
|
$(MAKE) -C $$PWD SRCROOT=$$PWD/$(SRCROOT) \
|
|
MODULEBUILDDIR=$(MODULEBUILDDIR) postbuild
|
|
--
|
|
2.21.0
|
|
|