smoverlay/net-im/spectrum/files/spectrum-1.4.7_remoteroster.patch
Sergey Morozov 13a59c3636 Add spectrum2 (XMPP transport to the other IM networks)
ebuilds in this commit:
spectrum/spectrum-1.4.8
spectrum/spectrum-2.0.0
spectrum/spectrum-2.9999
spectrum/spectrum-9999
swift/swift-2.0_rc1
swift/swift-9999

All ebuilds taken from official spectrum2 overlay

new file:   net-im/spectrum/Manifest
new file:   net-im/spectrum/files/spectrum-1.4.7_remoteroster.patch
new file:   net-im/spectrum/files/spectrum.cfg
new file:   net-im/spectrum/files/spectrum.confd
new file:   net-im/spectrum/files/spectrum.initd
new file:   net-im/spectrum/files/spectrum.symlink.cfg
new file:   net-im/spectrum/files/spectrum2.initd
new file:   net-im/spectrum/spectrum-1.4.8.ebuild
new file:   net-im/spectrum/spectrum-2.0.0_beta2.ebuild
new file:   net-im/spectrum/spectrum-2.9999.ebuild
new file:   net-im/spectrum/spectrum-9999.ebuild
new file:   net-im/swift/Manifest
new file:   net-im/swift/swift-2.0_rc1.ebuild
new file:   net-im/swift/swift-9999.ebuild
2014-05-03 22:56:29 +04:00

33 lines
1.4 KiB
Diff

diff --git a/src/spectrumbuddy.cpp b/src/spectrumbuddy.cpp
index 74d5194..910266c 100644
--- a/src/spectrumbuddy.cpp
+++ b/src/spectrumbuddy.cpp
@@ -36,10 +36,10 @@ SpectrumBuddy::~SpectrumBuddy() {
std::string SpectrumBuddy::getAlias() {
std::string alias;
- if (purple_buddy_get_server_alias(m_buddy))
- alias = (std::string) purple_buddy_get_server_alias(m_buddy);
- else
+ if (purple_buddy_get_alias(m_buddy))
alias = (std::string) purple_buddy_get_alias(m_buddy);
+ else
+ alias = (std::string) purple_buddy_get_server_alias(m_buddy);
return alias;
}
diff --git a/src/sql.cpp b/src/sql.cpp
index 8fbc64a..70bf5db 100644
--- a/src/sql.cpp
+++ b/src/sql.cpp
@@ -905,7 +905,8 @@ GHashTable *SQLClass::getBuddies(long userId, PurpleAccount *account) {
// create buddy
buddy = purple_buddy_new(account, buddyUins[k].c_str(), buddyNicknames[k].c_str());
purple_blist_add_buddy(buddy, contact, g, NULL);
- Log("ADDING BUDDY", buddyIds[k] << " " << buddyUins[k] << " subscription: " << subscription << " " << buddy);
+ purple_blist_server_alias_buddy(buddy, buddyNicknames[k].c_str());
+ Log("ADDING BUDDY", buddyIds[k] << " " << buddyUins[k] << " " << buddyNicknames[k] << " subscription: " << subscription << " " << buddy);
// add settings
GHashTable *settings = g_hash_table_new_full(g_str_hash, g_str_equal, g_free, (GDestroyNotify) purple_value_destroy);